Cannot open sketchup models with Keyshot demo

Started by niklassc, November 04, 2010, 12:21:36 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi, first of all, I'm new to the art of 3D-modeling and really impressed by the Keyshot software. I really want to learn how to make these cool 3D-renderings that I've seen on this site

But I cannot open my own models that I've done i Sketchup. They are very simple... just a cylinder so i can try render it in different ways in keyshot. I've tried with Sketchup 8 and 7. And even tried to save as a Sketchup 6-file. But is still doesn't work. What can I do to fix this?

the import program crashes and then it says "KeyShot discovered an error when importing this geometry.
I have a MAC and the latest demo of Keyshot (2.1.25)

I'd really appriciate some help!


Can you check and see if you have x11 installed?



Is it SketchUp v8?
This will be supported in v2.2 coming out by the end of November.




No it's sketchup v7 as well.  ???

After my first post i tried to export some random cubes from AutoCad (for Mac)  and I got the same message. "KeyShot discovered an error when importing this geometry"


Can you post an example?

If x11 isn't installed the importers won't work.


Sure, I'll fix it when I get home later today.
Do you want the model, crashreport or screenshot?

What's even more strange is that i can download & import Sketchup-models from googles 3D-warehouse without problems. But it doesnt work when i try with my own models

It works if I export them to .obj-files though

I have also tried to reinstall the program without result



Not at all, it's a few very basic cubes and pyramids just for trying keyshot out. The models i downloaded from google are more complicated - and they work without problem



Right now it's SketchUp 8 PRO

But I've tried Sketchup v7 (not PRO) on my computer also. And even tried to export the geometry to version 6 of Sketchup. Still doesn't work


Please post the sketchup file or send to and we'll take a look.


Hm, now I noticed that it works after I upgraded to SketchUp 8 PRO (and saving as SUv7).

Opening files from AutoCad still does not work though. Is the .dwg-format only available for PC at the moment? (my autocad-models works for my friend who has PC, but not on my mac)

Anyway, thanks alot for your help  :)


The dxf/dwg format is supported on both PC and Mac, but still in beta.