Plugin import issues KeyShot and Solidworks

Started by bart, August 30, 2014, 07:38:41 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi there,

I'm new to KeyShot and trying to make it work with SolidWorks R14.

I installed the plugin 3.0 for solidworks to import my model in KeyShot. When I use render from the plugin my model opened in keyshot, but way to big. I have to downscale it factor 100. At first I wasn't shure what happened since I only saw a black screen until I noticed it was way out of proportion.

The issue is, when I make a change in Solidworks and use update from the plugin, the model in KeyShot is back to it's large scale and I loose the materials I aplied earlier in KS. The changes that I made in Solidworks do update fine. It shure seems like it just produces a new model in KS instead of an update.

What could be wrong?


Have you set your units size in SW ? (mm, inches etc)



Hi Martin,

Thanks for the reply. Yes unit sizes are set in SW. I have the feeling it should have something to do with the linking between the two files. I also tried to update with the export function in the KS tool, but unfortunately the same result. Like I mentioned in the original post it looks like it just creates a new file in KS since I loose all the changes that were made in KS and start from the beginning with the update geometry from SW.


Same problem.I change the model scale to 0.01,then move the model,it moves pretty fast.Seems like the problem is the original scene is too small.