Author Topic: Keyshot ignores NURBS and Meshes from Rhino and destroys model  (Read 2669 times)

0 Members and 1 Guest are viewing this topic.

Offline orestispap

So here is the problem I am facing,

I made a fairly large model in Rhino (part of a cityscape along with detailed buildings) for a total of 228 Polysurfaces and 12581 Surfaces, whilen the entirety of the model comes up to 700x700m. As I tried to import it to keyshot (not through the plugin) the model gets so destroyed by tessellation that it is unworkable. I tried importing NURBS objects, using the NURBS mode, using the ExtractRenderMesh command and importing that Mesh (both in Shaded and Rendered View), even tried the Re-Tessellate key in Keyshot (which bizzarely can only decrease the Triangle and Polygon numbers). All for naught; the model is unworkable. I tried messing around with the Mesh options on Rhino but while the result changes, Keyshot stubbornly refuses to import anything of value. No matter what I try, the result is the exact same Mesh in Keyshot.

And now for the truly mindboggling part:

Keyshot did import the file right, without any problems one time. Just once. I had to change some things in the model though and therefore now I am with 1 and a half models.

Even if I did however ignore the broken parts that went from smooth to angular, keyshot shows the space between the Mesh rectangles and triangles as black void. I am at a total loss and have nothing to work with. What is more, the times that I tried importing more parts to the one working Keyshot file, the newly imported geometry was out of place, scale and its orientation was messed up, even though I changed none of the options in Keyshot, nor did I change the CPlane in Rhino.

PLEASE, I require help!

Offline RRIS

  • Sr. Member
  • ****
  • Posts: 304
  • Total likes: 5
  • Renze Rispens - industrial designer
Re: Keyshot ignores NURBS and Meshes from Rhino and destroys model
« Reply #1 on: August 21, 2019, 01:02:05 am »
Hm, it's most likely to do with the scale and size of your Rhino scene.

Have you tried removing all the complex geometry from your Rhino scene and replacing it with basic cubes that are similar in size?
What units are you working with in Rhino? Since you say your scene is 700x700 meters, I assume you're actually modeling in meters?
(What is precision you're letting Rhino work with? 5 decimals? You may want to dial that back as well if the rest doesn't work..)
When you open Keyshot, before importing your Rhino file, is the Keyshot scene also set to meters?

Importing objects that are 700 units in size shouldn't be difficult, as long as your units are the same across the workflow.
Importing a 700.000mm scene into a Keyshot file that uses mm's might be more tricky...

Offline simplyrhino

Re: Keyshot ignores NURBS and Meshes from Rhino and destroys model
« Reply #2 on: September 30, 2019, 02:59:31 am »
Is you Rhino model a long way from 0,0,0 - i.e. in site origin. If so, you should consider moving it so that it is centred around 0,0